Technical Information - saba

Contact North Technical Support provides help for Saba issues.

Please call 1-888-850-4628 for help.

 

Chrome

Chrome is our recommended browser for launching the Saba Meeting client.  Launch Chrome and install the Saba Meeting Chrome Connector.

Safari

Current versions of Safari will not launch the Saba Meeting client.  Older versions of Safari work but will stop working once updated. If you are currently using Safari with Saba Meeting without issue, do not allow Safari to update.  If Safari stops working, you will need to switch to Chrome and install the Saba Meeting Chrome Connector.  Should you choose to continue to use Safari, we recommend launching Saba Meeting using Chrome and testing audio so you are prepared should Safari stop working.

Firefox

Firefox does not work with older versions of Mac OS.  In order to use Firefox, upgrade to Mac OS 10.14.3 or higher and install the Saba Meeting Firefox Connector, or switch to Chrome and install the Saba Meeting Chrome Connector.

 

Helpful Instructions: